SysChat

SysChat (http://www.syschat.com/forum.php)
-   General Software (http://www.syschat.com/software-support/general-software/)
-   -   Strange NETSCAPE Error Message-all versions (http://www.syschat.com/strange-netscape-error-message-all-versions-3324.html)

b1caez01 04-01-2008 08:47 PM

Strange NETSCAPE Error Message-all versions
 
If you have a better way of cleaning up this issue let us know, a.s.a.p..

"The procedure entry point JS_DHashTableOperate could not be located in the dynamic link library js3250.dll" appears immediately upon install.

[ALL THE OBVIOUS CORRECTIVE MEASURES HAD BEEN DONE, SO DON'T BOTHER SUGGESTING ANY "CLEANUP" ACTIVITIES.]

That's it...no explanation as to what it meant or how to debug it! So, off to google...and boy...I was not the only one having met this BUG-on-STEROIDS!!! Only, I seemed to be the only one who met it using Netscape 7.2, and ultimately each of the other flavours of Netscape up to V9. The poor sods using FireFox were up in arms as there was no one coming forward to "fix" the bug. And no real suggestion as to what to consider in a fix.

Being too stupid to know better I went at it. I still had not solved the matter, but I made inroads, and later resolved it.

Process: before doing anything kill the whole MOZILLA folder in c:\Program Files\Common Files\Mozilla .

1. load fresh copy of Netscape (or FireFox as the case may be)
2. then try to start it going...if you meet a message not too unlike the one I quoted, and there will be others...forget it, you are not going to get pass this point
3. tried wiping all evidence of the install and both started afresh with the old copy and downloaded new copies...nothing changed.
4. went to google and did more research on the issue...hopeless
5. began thinking it through
6. the error message implied that it could not, find the js file or it could not hook up to it once found...where does it find files...REGISTRY!
7. checked out both USER and MACHINE and found that the necessary mozilla files were in the USER section but not the MACHINE section...exported the key in the USER section to my desktop and opened it with WORDPAD
8. repeated the same with the file in the MACHINE section...it was incomplete and empty in some cases of a reinstall
9. either WINDOWS INSTALLER was screwing things up, or an upgrade to one of my software, like Windows Updates...whatever...something had knocked the stuffing out of that key...
10. so I set out to remedy the situation and the two files below were the result
11. installed the new reg entry and tried again...got a bit farther with the prog, but not all the way, something was still amiss
12. without belabouring the hours of pulling my hair out...on a whim I went to the Program Files>Common Files>Mozilla.org> opened it up and copied and pasted the whole kit and kaboodle into the Netscape Program folder
13. fired it up and it now the Browser works faster then before.

BUT WITH ONE GIANT PROBLEM...it did not solve the mailer side of the equation...that I am still working on. The mailer now works but there are still bugs in it.

My fall back position is FireFox and ThunderBird...but I am not going to rest until I figure out what is screwing up Netscape...and which the net-research is telling me is on the horizon for FireFox. Forearmed is foreready...

The issue involves and installation anomaly and a registration anomaly...and finally, you must make sure that the files that are needed are in the locations they are supposed to be in...that is just a matter of tediously adding them one at a time from the GRE folder into the Program folder...and activating Netscp.exe...bummer

You can just copy and paste these files, then insert by double clicking on them.
--------------------------------------------------------------------------
Reg file for USER key...
--------------------------------------------------------------------------
[HKEY_CURRENT_USER\Software\mozilla.org]

[HKEY_CURRENT_USER\Software\mozilla.org\GRE]

[HKEY_CURRENT_USER\Software\mozilla.org\GRE\1.4f_20 03062408]
"BuildID"="2003062408"
"GreComponentsDir"="c:\\Program Files\\Common Files\\mozilla.org\\GRE\\1.4f_2003062408\\Componen ts"
"GreHome"="c:\\Program Files\\Common Files\\mozilla.org\\GRE\\1.4f_2003062408"
"Version"="1.4"

[HKEY_CURRENT_USER\Software\mozilla.org\GRE\1.4f_20 03062408\AppList]

[HKEY_CURRENT_USER\Software\mozilla.org\GRE\1.4f_20 03062408\AppList\Netscape 7.1b1 (en)]
"Name"="Netscape 7.1b1 (en)"
"PathToExe01"="C:\\Program Files\\Netscape\\Netscp.exe"

[HKEY_CURRENT_USER\Software\mozilla.org\GRE\1.4f_20 03062408\Installer]
"PathToExe"="C:\\Program Files\\Common Files\\mozilla.org\\GRE\\1.4f_2003062408\\Setup GRE\\setup.exe"

[HKEY_CURRENT_USER\Software\mozilla.org\GRE\1.4f_20 03062408\Main]
"Install Directory"="C:\\Program Files\\Common Files\\mozilla.org\\GRE\\1.4f_2003062408\\"

[HKEY_CURRENT_USER\Software\mozilla.org\GRE\1.4f_20 03062408\Uninstall]
"Uninstall Log Folder"="C:\\Program Files\\Common Files\\mozilla.org\\GRE\\1.4f_2003062408\\Uninstal l"
"Description"="GRE (1.4)"

[HKEY_CURRENT_USER\Software\mozilla.org\Mozilla]
"CurrentVersion"="1.8.1.3"
--------------------------------------------------------------------------
Reg file for MACHINE key
--------------------------------------------------------------------------
[HKEY_LOCAL_MACHINE\SOFTWARE\mozilla.org]

[HKEY_LOCAL_MACHINE\Software\mozilla.org\GRE]

[HKEY_LOCAL_MACHINE\Software\mozilla.org\GRE\1.4f_2 003062408]
"BuildID"="2003062408"
"GreComponentsDir"="c:\\Program Files\\Common Files\\mozilla.org\\GRE\\1.4f_2003062408\\Componen ts"
"GreHome"="c:\\Program Files\\Common Files\\mozilla.org\\GRE\\1.4f_2003062408"
"Version"="1.4"

[HKEY_LOCAL_MACHINE\Software\mozilla.org\GRE\1.4f_2 003062408\AppList]

[HKEY_LOCAL_MACHINE\Software\mozilla.org\GRE\1.4f_2 003062408\AppList\Netscape 7.1b1 (en)]
"Name"="Netscape 7.1b1 (en)"
"PathToExe01"="C:\\Program Files\\Netscape\\Netscp.exe"

[HKEY_LOCAL_MACHINE\Software\mozilla.org\GRE\1.4f_2 003062408\Installer]
"PathToExe"="C:\\Program Files\\Common Files\\mozilla.org\\GRE\\1.4f_2003062408\\Setup GRE\\setup.exe"

[HKEY_LOCAL_MACHINE\Software\mozilla.org\GRE\1.4f_2 003062408\Main]
"Install Directory"="C:\\Program Files\\Common Files\\mozilla.org\\GRE\\1.4f_2003062408\\"

[HKEY_LOCAL_MACHINE\Software\mozilla.org\GRE\1.4f_2 003062408\Uninstall]
"Uninstall Log Folder"="C:\\Program Files\\Common Files\\mozilla.org\\GRE\\1.4f_2003062408\\Uninstal l"
"Description"="GRE (1.4)"

[HKEY_LOCAL_MACHINE\Software\mozilla.org\Mozilla]
"CurrentVersion"="1.8.1.3"
--------------------------------------------------------------------------
I'm still banging my head against brick wall...

UPDATE:

Well got it solved and everything is running smoothly. Took a bit more tweaking, here and there but I'm done.

Following up on what I've already said above...I had to let Netscape set up new accounts and then transfer my saved settings and mail back into the fold. As far as the mail was concerned, you must set up your accounts to go directly to the actual folder...in which the "In box" is located. It used to be that Netscape set this up and then you just filled in the blanks, no more! ...you must do it by hand in the Preferences section for your mailer.


All times are GMT -4. The time now is 10:17 AM.


Copyright © 2005-2013 SysChat.com


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54